Roman

Can't access Premium Traffic

Recommended Posts

I recently bought my third Qashqai, this one from Nissan Leicester (130 miles away who provided the best deal). It is a 20 registration 1.3 DIG-T 160 Tekna 5dr DCT. The Premium Traffic which I have switched to ON only works when I am in my integral garage, presumably it is picking up my home wi-fi signal. I have a Samsung smartphone which is paired with the car. Am I correct in thinking that the system relies on picking up wi-fi signals when I am driving around the country?  If so it seems a poor system as presumably the whole of the UK is not covered by wi-fi signals. In my previous Qashqai a 2015 N-TEC+ the traffic information was always there no matter where I was in the country. I believe it received  radio signals.  I would add that my mobile is a PAYG which is not used at home as we have no mobile signal, so it is only used when away from home. 

I have followed the instructions on setting the Premium Traffic and the staff member at Nissan Leicester has also provided the same information. Hope that someone can resolve this problem.

Share this post


Link to post
Share on other sites
 

I think the signal comes through the radio antenna and may need setting up in the system to function correctly.
Not sure also if it is a subscription based service

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...