Nissan Owners Club - Nissan Forums Messages

Club Notice

Over 23000 Nissan vehicles for sale in the club classifieds - click here to view
Insure your Nissan with Owners Club Insurance - Get an insurance quote 
Review Your Nissan - Help others when it comes to buying a car like yours, review your Nissan Now


Recommended Posts

hallo all, I have a 2002 2.0l petrol x trail and have a problem starting it.  Most of the time it will start but only run very slowly for 30 seconds then pick up and run normally.   Other times it will refuse to start at all until it's been turned over for up to a minute.

Is this a common problem?   Any ideas would be appreciated.

 

Share this post


Link to post
Share on other sites
 

Hi Pancho...welcome to the Forum

I would definitely check the earth connections and in particular the earth leads on the underside of the vehicle coming from the battery.

If these are broken or heavily corroded then this can cause a whole range of issues.

Also, it may be worth running some cleaning solutions in with the fuel to clean the engine out.

Let us know what you find

Cheers,   Trevor

Share this post


Link to post
Share on other sites

Yes Trevor, sorry to take so long to get back. All earths and connections were ok so I put some injector cleaner in the tank and ran on petrol for 200 miles. It starts ok now. Thanks very much.

Share this post


Link to post
Share on other sites

Glad to hear you resolved the issue....i believe it always pays to run quality fuel through the engine rather than the supermarket fuel...may be a little more expensive but much better in the long run.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now