andybaz

xtrail - primera - QR20DE - engin light - P0335

Recommended Posts

hi all, i understand the primeras runs the same QR20DE engine, i have replaced my crank sensor, but looks like a chain issue, currently looking for a good website link for chain replacement, any pointers or views greatly appreaited.

 

Share this post


Link to post
Share on other sites
 

Well ... its currently bad news, after i replaced the crank sensor the car went fine - then P0335 pops up gain - so a full chain kit including VVT gear was ordered, yep take a look at ebay prices ..... so after paying £460+ for chain replacing ..... about 50mile later the light is back on - code P0335 crank position, which leaves 2 options now - as suspecting there is nothing wrong with any of the chain timing gear and the thoughts are - Either my crank sensor went deffective, the wiring loom that feeds the sensor is damaged somewhere and finally its the camshaft sensor and not the crank sensor.

So its back at the garage to have a 2nd new crank sensor & its 1st new cam shaft sensor fitted and see how we go.

 

Share this post


Link to post
Share on other sites

That's bad news but on the upside...at least the camchain is now replaced and less likely to just fail in service so peace of mind there.

If the cam sensor is faulty then this can flag a code but equally if the chain has any slack in it still then this also could be a likely cause

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...